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Introduction 
 
WaspQuickStore brings simplicity and power to multi-store, independent retailers like you.  This software 
makes it easy to setup your locations and maintain them from one, central location.  Since the cost of 
maintaining a fast, constant network connection between multiple locations is usually cost prohibitive, 
QuickStore consolidates and distributes data between locations nightly during a polling, or data transfer, 
operation.  This polling operation runs automatically each evening and only sends data that is new or has 
been changed.  This means that, at the start of each business day, each location will have been 
accurately updated information from all other locations. 
 

What you’ll find in this guide 
 
Use this guide to help you configure QuickStore to run in your multi-store environment.  In addition to the 
steps for configuring the software, this guide also contains an overview of the multi-store features 
contained in QuickStore and an explanation of the daily activities required to conduct your “batch” 
operation.   
 

Where to find additional information 
 
If you need information on using the basic functions or conducting normal operations, please refer to the 
online help found within QuickStore.  You can access Help by pressing the F1 key while using any screen 
in the software, or by selecting Help>Contents. 
 

Multi-Store Features  
 
Listed below are the features that set QuickStore apart and make it uniquely suited for a multi-store 
environment. 
 

• Customer, contracts, inventory quantities, purchase orders, receiving/transfer lists, sales, 
special orders, layaways and quotes can be entered and maintained at each physical 
location. 

 
• Information created by one store can be shared with any other store. 

 
• Purchase orders can be created for any store at any store.  This feature enables a 

centralized purchase ordering capability or the option to create purchase orders at each 
physical location.  Purchase orders created for other stores can be drop-shipped and 
received at the remote location. 

 
• Merchandise can be received from a purchase order at any location, for any location. 

 
• Transfers can be created for outgoing and incoming merchandise. 

 
• A single location is responsible for maintaining items that remain consistent throughout all 

locations.  This makes inventory setup and maintenance easier. 
 

• Individual stores can have individual pricing levels (5 pricing levels are available). 
 

• Reports can be run for one store or for all stores to easily view individual store performance, 
or to view data for your entire operation. 
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• Data between physical locations is consolidated and distributed during a daily polling 

operation.  This once-a-day data transfer is much more cost efficient than a constant on-line 
connection. 

 
• Only information changed during a designated period is transferred to your remote stores 

during the once-a-day polling operation.  This dramatically minimizes the time it takes for the 
data transfer to complete. 

 
• The polling operation can be conducted by modem transfer or via a network connection. 

 
• A full batch log records all your polling (data transfer) activities. 

 

Terminology 
 
 
Polling Location 
 
The polling location is the physical location that is usually the centerpiece of a multiple location operation.  
The polling location is either the largest store in the retail operation, a warehouse for ordering and 
distributing merchandise or the corporate headquarters.  This is the location determined to be the most 
central or most strategic to the entire retail operation.  The polling location is the location responsible for 
contacting each remote location in the nightly polling operation.  The polling location is also allowed to 
perform some maintenance/administrative tasks that cannot be performed by the remote locations. 
 
Some information in QuickStore can only be maintained (added or updated) at the polling location.  New 
inventory items, the user list, customer standards and inventory standards are a few examples of 
information maintained at the polling location.   Having this information maintained at the polling location 
simplifies the multi-store operation and provides a form of centralized control over critical items.  During 
the polling operation, this updated or new data will be distributed to the remote stores (that request it). 
 
 
Remote Locations 
 
Remote locations are those that will be polled by the polling location.  During the polling operation, the 
polling location will contact the remote locations and retrieve any new or edited data.  This data is then 
sent out to all remote locations. 
 
Stores  
 
These are the entities within the locations where business is conducted. 
 
Stores vs. Locations 
 
QuickStore differentiates between stores and locations and it is important not to confuse the two terms.  
Location is a broad term that refers to where the software is installed and where a database is located.  A 
location contains stores.  A location that is not the polling location is considered a remote location.  Within 
that remote location (remote because it is not the polling location) you will have at least one local store.  
This is the store that is physically at this location and.    Also within this location, you can setup remote 
stores.  These are stores that physically reside at a different location, but with which this location wants to 
communicate (receive information from or send information to).  The polling location can also have a local 
store (a store that is physically located at the polling location site) and remote stores (those stores located 
at a different location, but with which the physical store wants to communicate. 
 
You will need to install and configure the software at each location.  After installation, you will setup the 
local store for that location and each store that will be communicating with that location remotely (remote 
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store).  Keep in mind that each store that is remote, must be local at a different location: the location at 
which the store is setup as local will contain the database that houses its information.  In other words, you 
cannot have a remote store that is not local somewhere. 
 
Example: 
 
Brady’s Sporting Goods has 4 stores.   The largest store is where the business office is located.  Another 
store is located elsewhere in the city and is about half the size of the largest store.  The third and fourth 
stores are actually located in the same building.  This store conducts two types of business – one selling 
new equipment, and the other selling refurbished equipment.  These two stores are in the same building, 
but are setup as separate stores (different space, different inventory, etc.)  So, even though Brady’s 
Sporting Good is comprised of 4 stores, it is contained within three locations.  In this situation, QuickStore 
can be installed at each of the three physical locations.  The location containing the largest store would 
be setup as the polling location and the other locations are remote to this location.  The polling location 
would be setup with 1 local store (the store physically at that location) and the other stores would be in 
this location as remote.  The second location would be setup the same way, with the store physically 
located here as local, and the other three as remote.  The third location will have two local stores (the 
new and refurbished equipment) and the other stores will be setup as remote to this location.   
 
Below is an example of this store configuration: 
 

 
 
Batch Process (Polling Operation) 
 
The batch process refers to the nightly polling operation that retrieves and distributes data between the 
polling location and the remote locations.   
 
QuickStore allows each remote location to select how much information to share with the polling location.  
You can also select what data from what other locations you want to see at a specific remote location.  
For example, if you have 4 stores, each store can be set to send all data to the polling location, but each 
store can then be set to only receive certain information, rather than all collected data from all stores.  
These options are selected during the initial setup process and need to be done for each store.  By 
default, all locations send and receive all updated data.  So, in essence, while the polling location is the 
“collector” of the data, you can set up the remote locations to only send and/or receive certain 
information. 
 
A date range, known as a Batch Date is set in the remote locations that also determines what information 
is transmitted to the polling location.  Each record that is created or updated is “date-stamped” by the 
system and only those records that were edited or created during the date range are sent to the polling 
location (this prevents ALL data from being sent every time the polling operation is conducted and results 
in markedly less time tied up transferring information). 
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Below is an example of the polling process: 
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Setting up the Software at Each Location  
 
The multi-store version of QuickStore runs on an independently maintained set of data at each location.  
This means that each location has its own database, or repository where data is stored.  In order for the 
polling process to work properly, each location must be carefully configured.  The process is not difficult, 
but it must be completed accurately for QuickStore to work properly. 
 
Note:  After you have correctly setup each location, you will not need to do it again.  The settings should 
not be modified unless you first speak with Wasp Technical Support. 
 

Program Installation and Setup 
 
For specific information about program installations, please refer to the Quick Start Guide.  After installing 
and registering the software, you should immediately perform the following setup procedures. 
 

1. Define All Stores – Local and Remote: After installing the software at this location, you need to 
define stores that are local to this location (physically located at this location) and all stores that 
need to be viewed from this location (remote stores).  You must set up at least two stores – one 
local and one remote.  In most cases, you will set up all of your stores at either local or remote at 
each location at which you install the software.   
 
For example, if you have 4 stores, you will setup all 4 stores at each location.  If you want to have 
4 locations (one location per store), you will install the software at each location and setup the 
store that is physically located at each individual location as a local store, and then setup the 
other three as remote locations.  You would repeat these steps (software installation, store setup) 
at each location.   
 
To add new stores: 
 

a. From the Main screen, select Setup > Store > Add a New Store.   
 

 
 
A message similar to the one below appears: 
 

 
 

b. Select Yes on the message screen.  The Add a New Store screen appears. 
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c. Enter the store number and all other information for this store.  Set up the first store 
carefully; subsequent stores you add use the settings from the first store. 
  

d. Click OK to save the new store information.  Keep in mind that after a store’s information 
has been saved, the only way to change a store number is to delete the store, then add it 
again with the correct store number. 

 
Note:  If you have already setup your stores at a different location, you can copy the stores and 
their settings to another location by copying the STORE.TPS in the program’s data directory to 
the new location’s data directory.  You should only do this during the initial setup.  Make sure that 
you go into the software and correctly identify each store as local or remote for the new location. 
 

2. Define the Location Type – Polling or Remote: There are two types of potential locations in a 
multi-location environment: the polling location and a location that will be polled (remote location).    
There will only be one polling location in your multi-store environment, but there may be many 
locations that will be polled. 
 
To set the type of location: 
 

a. From the Main screen, select Setup > Multi-Location Polling. 
 

 
 
The Multi-Location Polling screen will appear. 
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b. Set the location type.  By default this is set to Not Used.   
 
If the location is the polling location, select This location will perform the polling 
operation and contact all remote locations.  The screen will then look like this: 
 

 
 
Set the station number that will perform the actual polling in the Station to run the Batch 
update process field.  This is the actual computer that will be contacting the remote 
locations.  You can also select to set a Batch Start Time.  This tells the system to wait a 
designated number of minutes after the Batch Process has been started before 
attempting to contact the remote locations.  The other options on the tabs for this screen 
should be left at their default settings. 
 
If the location is remote, meaning it will be polled, select This location is a remote location 
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that will be polled.  The screen will look like this: 
 

 
 
There are a number of options that can be set on the tabs for this selection; however, 
most should be left at their default settings.  The most important item is found on the 
Method Tab.  The items on the Method Tab define how the location will be contacted.  
Below is an example of the Method Tab: 
 

 
 
For modem connections, make sure the login name and password you enter matches the 
setting for this store at the polling location.  Network connections default to a standard 
transfer directory.   
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The Receive I and Receive II tabs allow you to select what information this store wants 
to receive from other stores. 
 
For more information about selecting the information to send and receive, press F1 while 
on the Multi-Location Polling screen to view the online help.  If you are unsure what to 
set, leave the settings at their defaults. 
 

3. Complete Store Setup: After defining the type of location, you can complete the setup by 
marking the stores you setup as local or remote.  Remember that a local store is one that 
operates at the current physical location.  A remote store operates at another location (and, thus, 
has a separate database). 
 
To Mark Stores as Remote or Local: 
 

a. From the Main screen, select Setup>Stores. 
 
A list of the stores you have setup will appear. 
 

  
 

b. Click on the store you want to edit first (you will need to edit all stores).  The Changing 
Store Settings screen appears with the name of the selected store appearing at the top 
of the screen. 
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c. On the General tab, set the store type to Remote or Local. 
 

d. (Polling location only) If you are in the polling location, the Polling tab will appear on 
this screen for remote stores. 
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This tab contains settings for the contact method.  The contact method must be 
established for each remote store.  For modem connections, the user name and 
password must match the user name and password defined by the store at the remote 
location (the location where that store physically operates).  For network connections, the 
incoming and outgoing directories must be the same “logical” directories defined by the 
store at the remote location. 
 

e. Click on the Options tab.   
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You must set the options on this tab for each store.  Press F1 while using this screen for 
detailed information on these options. 
 
Note:  You should only allow purchase orders for special orders at one location.  Allowing 
this at more than one location could potentially cause special orders to be placed onto 
more than one purchase order.  The same is true for ordering inventory below desired 
stock levels. 
 

4. Setup the Modem 
 
The polling location always requires the modem to be properly configured in order for the batch 
operation to run.  Remote locations require a modem to be configured so they can be contacted 
by the polling location.   
 
To Setup the Modem: 
 

a. From the main menu, click Setup>Modem. 
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The Modem Configuration screen appears. 
 

 
 

b. Always set the modem to Hayes Compatible (default) and select the proper COM port.  
The COM port is the communication port on your computer to which you have attached 
the modem.  Do not change the settings on the other tabs for this screen unless 
instructed to do so by Tech Support.  If the modem does not appear to function properly, 
try the Hayes Compatible (alternate) option. 
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The Polling Operation 
 
This section describes the various components of the polling operation.  This process is known as the 
“Daily Batch Process” and encompasses all of the operations performed with the polling operation. 
 
This process is typically run at the end of the business day and is run daily.  The polling location initiates 
the process and the remote locations must be ready to be contacted by the polling location. 
 

Transferring Ownership 
 
Information created at a store is “owned” by that store.  Changes cannot be made to that information by 
another store.  For example, if Store 2 creates an invoice, only Store 2 can modify or deliver items from it 
unless and until ownership is transferred to another store (at another location).  These transfers take 
place during the polling operation.  Once the transfer is completed, the newly assigned store becomes the 
owner of that item and can modify it as needed.  For specific information on how to mark an item for 
transfer, please refer to the QuickStore online help. 
 

Batch Date Ranges 
 
As mentioned previously, the date range that will be transmitted to the polling location is set at the remote 
locations.  That date range will also be used by the polling location to determine what information is sent 
back to the remote locations.  The polling location processes all information sent and transmits the 
information that the remote locations requested.  Batches can be re-run for the same date range if 
needed. 
 

Process Steps 
 
The batch process is divided into four steps that are performed at each remote location.  Each step 
represents a file transfer. 
 

1. The first file transfer sends a log (file) of record modifications to the polling location for all stores 
listed as remote to the location currently being polled.  Any changes made from this location to a 
store that is remote, or housed in another location, will be sent at this time.  (See the table above 
for items that can be edited by any store at any time.) 
 

2. After all the logs are received by the polling location, they are distributed to each remote store 
and processed.  
  

3. Records are sent to the polling location from the store that is local to the location currently being 
polled. 
 

4. This file of changes to the local store is transmitted to a remote location that has been setup to 
receive information from this store (this local store is setup as a remote store at the receiving 
location).  The file will be modified to only contain that information requested by the remote 
location. 
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Starting the Process 
 
At the polling location:  
 

1. At the end of the business day, from the Main Menu select Activities > Daily Batch Update 
Process.  The Batch Update Process – Polling Location screen appears. 
 

2. Select the Start button to begin the transfer.  The process will begin immediately, or, if a wait 
time has been entered on the Multi-Location Polling Setup screen, the system will start 
after the designated wait interval. 
 

At the remote locations: 
 

1. From the Main Menu, select Activities>Daily Batch Update Process. The Batch Update 
Process – Remote Location screen appears. 
 

2. On the Batch Update Process screen, the Current Batch Start date defaults to the day after 
the last successful batch date.  The End date defaults to the current date.  Usually you will not 
need to change these dates.   
 
Click the Start button to begin the process.  The system will wait for contact by the polling 
location. 

 

Failed Connections 
 
If an attempt to connect to a remote location fails, the process will move on to the next location requiring 
contact, or it will wait the specified time (entered on the Multi-Location Polling Setup screen) to retry the 
current location.  After several failed contact attempts on a given step in the process, the system will 
exclude the problem location and continue with the other locations.  Any location excluded from the 
current batch can be re-run for the failed dates the next time the batch is run. 
 

Resetting the Process 
 
After the batch process is started, the program sets a status flag that helps ensure all functions are 
properly completed, both at the remote locations and the polling location.  If a batch is currently running, 
you will not be able to use the system for normal activities until it is finished.  You can manually reset the 
batch by clicking the Reset button on the Batch Update Process screen.  Resetting the batch causes the 
entire process to start over from the beginning.  Doing this in the middle of a batch process will not cause 
a problem to the system, but you will need to re-run the entire batch process for the same dates the next 
time the batch is executed. 
 

Sending All Data on an Item Instead of Only New/Updated Data (Sending 
Complete Files) 
 
Usually, the batch process only sends information that has been changed during the designated batch 
dates (either updated or added).  This ensures your transmission times are very small.  You can select to 
send entire records, if needed, rather than just updated information for select items.   
 
At remote locations, you can select to send all customers and inventory quantities for the store local to 
that location.   
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At the polling location, you can send all customers, inventory quantities, as well as any information that is 
maintained only at the polling location such as: inventory items, users, sales tax rates, etc.  If you want to 
send all sales information, run a batch for the desired time period.  Keep in mind that the more 
information you send, the longer the transmission will take. 
 
The need to send complete file listings should be very limited.  An example of when you might want to 
send complete files from the polling location is for new locations coming on-line.  In this case, you could 
send all files from the polling location the first time you run the batch process for the new remote location. 
 
To send complete files: 
 

1. On the Batch Update Process – Polling Location screen, select the File tab.   
 

2. On the File tab, select the files you want to send as complete.  If you are bringing a new remote 
location on-line, you should check all files so the remote location receives a complete copy of all 
data maintained by the polling location. 
 

3. Continue with the batch process as normal. 
 

Omitting a Store from the Current Batch 
 
To omit a store from the current polling operation, highlight the store (or stores) in the list on the Batch 
Update Process – Polling Location screen, right-click, then select Exclude. 
 
Important Note: Stores excluded from the current batch will not be included in any future batches until 
you right-click on the listing again and select Include. 
 

Special Multi-Store Features 
 

Setting the Current Local Store 
 
If more than one local store is defined at the current location (see the example in the Terminology 
section), invoices can be created at either store from either store.  Which store you are creating an 
invoice for is determined by the store selected in the QuickStore toolbar: 
 

 
 
You can change the store by clicking the drop down list and selecting a different store. 
 

Transferring Merchandise Between Stores 
 
The Enterprise version has the ability to transfer merchandise between any two stores.  You can transfer 
merchandise: 
 

• Out of a store 
• Into a store 
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• Out of a store, then into a different store (in this scenario, the software adjusts the inventories in 
both stores) 

 

How to Transfer Inventory: 
 

1. From the Main Menu, select Activities>Receiving/Transfers or select the Receive button from 
the toolbar: 
 

 
OR 
 
 

 
 
 The Receiving and Transfer Lists screen appears. 
 

2. Select the List button to add a new list. 
 

 
 
The Adding List screen appears. 
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3. Set the Type of list as Transfer. 
 

 
 

4. Select the Incoming and Outgoing stores. 
 

5. Add items to the transfer by scanning the barcodes of the items you want to transfer. 
 

6. Click the OK button when you are finished adding items.  The items on the list will be subtracted 
from inventory, added to inventory, or both. 

 

Transferring Stock for Special Order Items 
 
You can transfer items from stock at one store to a particular special order line item as long as: 
 

• the special order item requires fulfillment (see the online help for more information) and 
 

• the special order is viewable at the current location. 
 
To do this: 
 

1. From the Main Menu, select Activities>Receiving/Transfers or select the Receive button from 
the toolbar (see screen shots above) 
 

2. Select the List button to add a new list. 
 

3. Set the Type of list as Transfer Out and In. 
 

4. Select the Incoming and Outgoing stores. 
 

5. Use the F2-Add Spec button to select the special order items needed by the store receiving the 
transfer.   
 

6. Click the OK button.  Transfers for special order items move the item out of stock from the 
sending store and into hold at the receiving store. 
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Known Issues 
From a data management perspective, the Polling Operation (Batch Process) is a very sophisticated 
and complex operation which accurately distributes new and edited information between locations.  
Overall, the polling operation is simple and works exactly as you would expect – distributing changes and 
updates while receiving the information you have selected.  However, if you run an operation that creates 
Purchase Orders for Special Orders that were not created at the same physical location, there are 
certain scenarios that can produce invalid on-order quantities for a particular inventory item.  Although a 
discrepancy can occur, the Month – End Process at the location with an on-order discrepancy in their 
inventory) can be used to verify and update each inventory item’s on-order quantities to match the 
quantities currently on your Purchase Orders. 
 

Receiving Items 
 
When you receive items on a Purchase Order Receipt or Transfer, the items will always be added to 
your stock.  If an item was received for a special order item that was deleted at another location, the 
quantity will automatically be added to the stock for the store. 
 

Special Orders 
 
All known issues that can arise in the Batch Process result in incorrect on-order quantities for stock or 
special orders.  Although the on-order quantity for an inventory item could be incorrectly reflected in 
inventory, it will not cause a special order item requiring ordering or fulfillment to be skipped. 
 
The on-order quantities can become incorrect because of the nature of the operations that can be 
performed on an individual special order item (i.e. Purchase Orders can be created at a location that 
does not own the Special Order, and Purchase Order Receipts can be created at a location that did not 
create the Special Order or Purchase Order).  All three items, a Special Order, Purchase Order and 
Purchase Order Receipt affect the on-order quantities for an item, and all three could be created or 
revised at a different location at the same time.  In most cases, the Batch Process can handle the 
revisions and will keep all inventory values accurate. 
 

Scenarios to Avoid 
 
Do not delete or revise a Purchase Order on the same day the Purchase Order is received at a remote 
location. 
 
Try to avoid revising or deleting Purchase Order Receipts with items received for special order items for 
another location after the batch has been run.  The special order items could have been delivered before 
the revisions are received in the batch and would result in negative inventory values for the delivered 
items. 
 
Do not create a Purchase Order Receipt for the same Purchase Order at different locations on the 
same day. 
 

Recommendations 
 
Do not create Purchase Orders for special order items for a store at more than one location. 
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Avoid creating Purchase Orders for inventory items below reorder points at more than one location.  You 
could create a double order if the Purchase Orders are done on the same day. 
 
There is no need to remove an item on a Purchase Order for a Special Order item which was removed 
from a Special Order at a remote location.  The Batch Process will automatically set the item to an item 
on-order for stock.  The item on the Purchase Order could be revised once the batch has performed the 
revisions. 
 


